CreditorWatch Reports & API services are back to normal

Incident Report for CreditorWatch

Resolved

All services are back to normal. This incident has been resolved.
Posted Jan 15, 2026 - 13:01 AEDT

Monitoring

A solution has been implemented, and the team is continuing to monitor it.
Posted Jan 15, 2026 - 12:03 AEDT

Investigating

The team is currently investigating the issue.
Posted Jan 15, 2026 - 11:58 AEDT
This incident affected: CreditorWatch APIs (Credit Report APIs, UBO APIs, Verify APIs, ApplyEasy APIs, PPSR APIs) and CreditorWatch portal (Credit reports and search, Customer list and alerts, Applications (ApplyEasy v2), Debtor Management, DebtorLogic, PPSR).