CreditorWatch services unavailable
Incident Report for CreditorWatch
Resolved
This incident has been resolved.
Posted Sep 24, 2024 - 15:13 AEST
Monitoring
CreditorWatch services have been restored at 2.42pm. We continue to monitor service performance for any issues.
We sincerely apologise for any inconvenience caused.
Please report any further issues to support@creditorwatch.com.au.
Posted Sep 24, 2024 - 14:54 AEST
Update
CreditorWatch services remain unavailable. The issue has been identified. We are actively working to rectify the issue as soon as possible.
Further updates within 60 mins.
Posted Sep 24, 2024 - 14:03 AEST
Identified
CreditorWatch services are currently unavailable. The issue has been identified. We are actively working to rectify the issue as soon as possible.
Further updates within 60 mins.
Posted Sep 24, 2024 - 13:00 AEST
Investigating
CreditorWatch services are experiencing an issue. Our teams are working on to identify the issue.
Further updates in next 30 minutes.
Posted Sep 24, 2024 - 12:27 AEST
This incident affected: CreditorWatch - API, CreditorWatch - Application Portal, and CreditorWatch Express.