We are experiencing an issue with logins

Incident Report for CreditorWatch

Resolved

This incident has been resolved. We apologise for the inconvenience and will investigate root cause to mitigate the issue from occurring again.
Posted Jan 06, 2026 - 12:12 AEDT

Monitoring

We are currently reviewing the issue and monitoring a fix.
Posted Jan 06, 2026 - 11:18 AEDT

Investigating

We are currently aware of an issue with logins affecting a small number of users. We are investigating and will provide and update as soon as possible.
Posted Jan 06, 2026 - 11:08 AEDT
This incident affected: CreditorWatch APIs (Credit Report APIs, UBO APIs, Verify APIs, ApplyEasy APIs, Collect APIs, PPSR APIs) and CreditorWatch portal (Credit reports and search, Customer list and alerts, Applications (ApplyEasy v2), Debtor Management, DebtorLogic, PPSR).