Apply Easy - Intermittent disruption to capturing signatures on additional documents included in e-signature envelopes

Incident Report for CreditorWatch

Resolved

This incident has been resolved.
Posted Feb 26, 2026 - 10:47 AEDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 25, 2026 - 15:55 AEDT

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 25, 2026 - 10:04 AEDT

Investigating

Apply Easy is currently experiencing an intermittent issue when capturing signatures for additional documents included in e-signature envelopes. We are working with our partners to resolve this. We encourage you to verify e-signature documents that are completed for all required signatures before approving applications.
Posted Feb 25, 2026 - 10:03 AEDT
This incident affected: CreditorWatch portal (Applications (ApplyEasy v2)).