CreditorWatch PPSR service is currently experiencing issues with our platform

Incident Report for CreditorWatch

Resolved

This incident has been resolved.
Posted Jun 26, 2025 - 13:39 AEST

Identified

We are continuing to investigate this issue.
Posted Jun 26, 2025 - 13:39 AEST

Update

We are continuing to investigate this issue.
Posted Jun 26, 2025 - 13:38 AEST

Investigating

We are currently investigating reports of issues with our platform. CreditorWatch is currently investigating these reports and will provide an update shortly.
Posted Jun 26, 2025 - 13:38 AEST
This incident affected: CreditorWatch portal (PPSR).