PPSR.gov.au payment systems down

Incident Report for CreditorWatch

Resolved

PPSR.gov.au is back up and operational.
Posted May 18, 2026 - 15:56 AEST

Monitoring

We are monitoring the integration with PPSR.gov.au
Posted May 18, 2026 - 14:56 AEST

Identified

The PPSR.gov.au is currently experiencing technical issues with its payment system. This issue is affecting all PPSR-related functionality, such as searching for PPSR registrations, creating, amending & discharging registrations. We will monitor the integration and inform you once the systems are back online.
Posted May 18, 2026 - 13:56 AEST
This incident affected: CreditorWatch portal (Credit reports and search, PPSR).