Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 21, 2026 - 18:30 AEDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Feb 19, 2026 - 13:34 AEDT
Update
ASIC maintenance is scheduled from Saturday 6:30pm to Sunday 6:30pm AEDT. NZ Report maintenance is scheduled from Sunday 10:00am to 9:00pm AEDT.
Posted Feb 19, 2026 - 12:51 AEDT
Scheduled
Australian Securities and Investments Commission (ASIC) will be undergoing scheduled maintenance and will therefore be unavailable during this period of time.
Posted Jan 16, 2026 - 11:19 AEDT
This scheduled maintenance affected: CreditorWatch APIs (Credit Report APIs, UBO APIs), CreditorWatch portal (Credit reports and search, New Zealand Credit Reports, Applications (ApplyEasy v2)), Partner services (Australian Securities and Investments Commission (ASIC, asic.gov.au)), and Apply Easy (legacy).