Slower than expected credit report PDF downloads

Incident Report for CreditorWatch

Resolved

This incident has been resolved.
Posted Jun 29, 2026 - 15:45 AEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 29, 2026 - 14:53 AEST

Update

We are continuing to investigate this issue.
Posted Jun 29, 2026 - 12:48 AEST

Investigating

Some customers may be experiencing slow responses, intermittent errors, or timeouts when downloading credit report PDFs. Our team is working to restore normal performance.

Thank you for your patience.
Posted Jun 29, 2026 - 12:40 AEST
This incident affected: CreditorWatch portal (Credit reports and search).